设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

笔底分型主图指标公式+顶分型预警指标源码

来源:未知 编辑:admin 时间:2018-03-01
导读: 底分型是有三根K线组成,中间的一根低点为三根中的最低点,高点也是其中高点的最低点,同理还有顶分型,两者是用来判断股票价位的,但是在实战中必然会需要投资者了解其基本的
 
  底分型是有三根K线组成,中间的一根低点为三根中的最低点,高点也是其中高点的最低点,同理还有顶分型,两者是用来判断股票价位的,但是在实战中必然会需要投资者了解其基本的指标公式源码,下面就笔底分型主图指标与顶分型预警指标的源码进行分析: 顶底分型主图

  【笔底分型主图】

  底分型是具有反弹或反转趋势的,一般用来看做是股票到达底部的信号,其具体的指标公式源码如下:

  重心线:(H+L+O+C*3)/6;

  NX:=(3*CLOSE+LOW+OPEN+HIGH)/6;

  牛线:=(20*NX+19*REF(NX,1)+18*REF(NX,2)+17*REF(NX,3)+16*REF(NX,4)

  +15*REF(NX,5)+14*REF(NX,6)+13*REF(NX,7)+12*REF(NX,8)+11*REF(NX,9)

  +10*REF(NX,10)+9*REF(NX,11)+8*REF(NX,12)+7*REF(NX,13)+6*REF(NX,14)

  +5*REF(NX,15)+4*REF(NX,16)+3*REF(NX,17)

  +2*REF(NX,18)+REF(NX,20))/210;

  牛熊线:MA(牛线,6),COLORGREEN,LINETHICK2;

  简底:=H>REF(H,1) AND REF(H,1)REF(L,1) AND REF(L,1)

  简顶:=HREF(H,2) AND LREF(L,2);

  包含1:=REF(H,1)>=REF(H,2) AND REF(L,1)<=REF(L,2);

  包含2:=REF(H,1)<=REF(H,2) AND REF(L,1)>=REF(L,2);

  包底1:=H>REF(H,2) AND REF(H,2)REF(L,1) AND REF(L,1)

  包底2:=H>REF(H,1) AND REF(H,1)REF(L,2) AND REF(L,2)

  包顶1:=HREF(H,3) AND LREF(L,3);

  包顶2:=HREF(H,3) AND LREF(L,3);

  复底:=IF(包含1,包底1,IF(包含2,包底2,简底));

  复顶:=IF(包含1,包顶1,IF(包含2,包顶2,简顶));

  底分型:=IF(BARSLAST(CROSS(牛熊线,重心线))>3,FILTER(BACKSET(FILTER(复底 AND 重心线<牛熊线,3),2),1),0);

  顶分型:=IF(BARSLAST(CROSS(重心线,牛熊线))>3,FILTER(BACKSET(FILTER(复顶 AND 重心线>牛熊线,3),2),1),0);

  STICKLINE(底分型,C,O,8,0),COLORFF00FF,LINETHICK2;

  STICKLINE(底分型,C,O,3,0),COLORFF00FF,LINETHICK2;

  STICKLINE(底分型,H,L,1,0),COLORFF00FF,LINETHICK2;

  STICKLINE(顶分型,C,O,8,0),COLORYELLOW,LINETHICK2;

  STICKLINE(顶分型,C,O,3,0),COLORYELLOW,LINETHICK2;

  STICKLINE(顶分型,H,L,1,0),COLORYELLOW,LINETHICK2;

  DRAWTEXT(底分型,L*0.99,'底型'),COLORYELLOW,LINETHICK1;

  DRAWTEXT(顶分型,H*1.02,'顶型'),COLORYELLOW,LINETHICK1;

笔底分型主图

  通过观察其源码能够发现其中包含的有重心线、牛熊线以及顶底分型的标志,用于判断股票的价位,进而寻找合适的买卖点位置。

  【顶分型预警指标】

  是与底分型相反的,指的是第二根K线的上点是3根K线中上点的最高点,同时第二根K线的下点也是3根K线中下点的最高点,其本质是上升后转折成下降,具体的源码如下:

  V00:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);

  V01:= HIGH

  V02:= REF(HIGH,2) > HIGH AND REF(LOW,2) > LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);

  V1:= COUNT(V00,4)>=2 AND HHVBARS(HIGH,4) = 1 AND V01;

  V2:= COUNT(V00,5)>=2 AND HHVBARS(HIGH,5) = 2 AND V02;

  V3:= COUNT(V00,5)>=2 AND HHVBARS(HIGH,5) = 1 AND V01;

  V4:= COUNT(V00,6)>=2 AND HHVBARS(HIGH,6) = 2 AND V02;

  XG: V1 OR V2 OR V3 OR V4;

顶分型预警指标

  主要是用于判断股票的价位走势以及顶部高点位置,做好买卖交易的策略,如果您还想要了解更加专业的技术分析知识,或者是相关的指标公式,请点击,帮助您从股海中选出能够获利的操作股票。

 

网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top