设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

源码解读“底部介入”与“回踩关键位”指标公

来源:未知 编辑:admin 时间:2018-03-01
导读: 股市轮回主要是底部筑底,启动拉升,回踩关键点位,再次筑底拉升,然后卖出获利,其中筑底和回踩关键点位是两个重要的关注点,是介入点的操作信号,具体的形态分析可以通过股
 
  股市轮回主要是底部筑底,启动拉升,回踩关键点位,再次筑底拉升,然后卖出获利,其中筑底和回踩关键点位是两个重要的关注点,是介入点的操作信号,具体的形态分析可以通过股票公式中的指标源码进行分析。

  【底部介入指标】

  讲解的是通过量能的买卖以及进出量的变化关系,选择买卖点以及短线介入的点位,具体的源码公式如下:

  AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

  买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE

  卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE

  进出量:=买量+卖量,COLOR00FFFF;

  五日内净流入:=SUM(进出量,5),LINETHICK1,COLORLIBLUE;

  N:=9;M:=14;N1:=6;

  TYP := (HIGH + LOW + CLOSE)/3;

  CC1:=(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M)),COLORFF00FF;

  C1:=SMA(CC1,3,1);

  C2:=SMA(C1,3,1);

  C3:=3*C1-2*C2;

  CB1:=EMA(C3,5);

  LC := REF(CLOSE,1);

  RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;

  RSI:=(RSI1-50)*5;

  R1A:=SMA(RSI,3,1);

  D1:=SMA(R1A,3,1);

  J1:=3*R1A-2*D1;

  RR1:=EMA(J1,5);

  RR2:=REF(RR1,1);

  RR:=RR1>RR2;

  卖出:=REF(RR,1)=1 AND NOT(RR) AND CB1>100;

  R1:=(CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*200;

  R2:=EMA((CLOSE-(LLV(LOW,5)))/((HHV(HIGH,5))-(LLV(LOW,5)))*100,4)*2;

  R3:=EMA(0.618*REF(R2,1)+0.382*R2,2);

  R4:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);

  R5:=POW(MA(LOW,5),2)+MA(LOW,5);

  R6:=POW(MA(HIGH,5),2)+MA(HIGH,5);

  R7:=(R4-LLV(R5,64))/(HHV(R6,64)-LLV(R5,64))*150+65-10;

  R8:=SMA((SMA(R7,3,1)*1.5-100),3,1);

  R9:=3*(SMA(R7,3,1)*1.5-100)-2*R8;

  R10:=(HIGH+LOW+CLOSE*2)/4;

  R11:=(R10-(EMA(R10,13)))*100/(STD(R10,13));

  R12:=EMA((EMA(R11,5)),13)+200-100;

  R13:=(SMA(R1,3,1))+R2+(SMA(R7,3,1)*1.5-100)+R12;

  R14:=(SMA((SMA(R1,3,1)),3,1))+R3+R8+(EMA(R12,10));

  R15:=(3*(SMA(R1,3,1))-2*(SMA((SMA(R1,3,1)),3,1)))+(3*R12-2*(EMA(R12,10)))+

  R9+(3*R12-2*(EMA(R12,10)));

  R16:=(HIGH+LOW+CLOSE)/3;

  R17:=(R16-MA(R16,34))/(0.015*AVEDEV(R16,34));

  R18:=(HIGH+LOW+CLOSE+R16)/4;

  R19:=(R18-(EMA(R18,24)))/(STD(R18,24))*100;

  R20:=(R16-MA(R16,24))/(0.015*AVEDEV(R16,24));

  R21:=(((EMA(R19,5))+R20+R17)/3+165)/4;

  R22:=(R13+R14+R15*30)/32/5-15;

  买卖: EMA(((R21+R22)/2/1.1),1);

  阻力:MA(买卖,3),COLORWHITE,LINETHICK2;

  IF(买卖< 阻力,买卖,DRAWNULL),COLORGREEN,LINETHICK2;

  IF(买卖>=阻力,买卖,DRAWNULL),COLORRED,LINETHICK2;

  短线介入:IF(CROSS(((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*250),0) AND CROSS(买卖,阻力) AND 阻力>0 AND 阻力>REF(阻力,1) AND 五日内净流入>0 AND 五日内净流入>REF( 五日内净流入,1),90,0),COLORRED;

  DRAWICON(CROSS(买卖,阻力) AND ((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*250)>REF(((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*250),1),阻力,1);

  DRAWICON(CROSS(阻力,买卖),阻力-3.66,2);

  DRAWICON(卖出,买卖*1.13,6);

  DRAWICON(CROSS(买卖,100),买卖*1.10,9);

  DRAWICON(CROSS(买卖,120),买卖*1.06,35);

  DRAWICON(CROSS(((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*250),0) AND CROSS(买卖,阻力) AND 阻力>0 AND 阻力>REF(阻力,1) AND 五日内净流入>0 AND 五日内净流入>REF( 五日内净流入,1) ,28,11);

  STICKLINE(CROSS(((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*250),0) AND CROSS(买卖,阻力) AND 阻力>0 AND 阻力>REF(阻力,1) AND 五日内净流入>0 AND 五日内净流入>REF( 五日内净流入,1),22.8,0,1,0),COLORRED;

  DRAWTEXT(CROSS(((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*250),0) AND CROSS(买卖,阻力) AND 阻力>0 AND 阻力>REF(阻力,1) AND 五日内净流入>0 AND 五日内净流入>REF( 五日内净流入,1),88,'←━金牛狂飙'),COLORLIMAGENTA;

  VAR2W:=REF(LOW,1);

  VAR3W:=SMA(ABS(LOW-VAR2W),3,1)/SMA(MAX(LOW-VAR2W,0),3,1)*100;

  VAR4W:=EMA(IF(CLOSE*1.3,VAR3W*10,VAR3W/10),3);

  VAR5W:=LLV(LOW,30);

  VAR6W:=HHV(VAR4W,30);

  VAR7W:=IF(MA(CLOSE,58),1,0);

  VAR8W:=EMA(IF(LOW<=VAR5W,(VAR4W+VAR6W*2)/2,0),3)/618*VAR7W;

  VAR9W:=IF(VAR8W>100,100,VAR8W);

  STICKLINE(VAR9W>-150,0,VAR9W,2,0), COLORLIMAGENTA;

  底部吸筹指标:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, COLOR00FF00;

  STICKLINE(CROSS(底部吸筹指标,-24),88,0,1,0), COLORWHITE;

  DRAWTEXT(CROSS(底部吸筹指标,-24),89,'建仓');

  可能放量拉升:=IF(CROSS(底部吸筹指标,-24),1,0), COLORWHITE;

  短线可买:STICKLINE(REF(KDJ.J,1)<0 AND KDJ.J>0,88,0,1,0),COLORGREEN;

  DRAWTEXT(REF(KDJ.J,1)<0 AND KDJ.J>0,90,'←短线介入'),COLORYELLOW;

  强弱分界线:50,COLORLIBLUE,DOTLINE;

  风险顶:100,COLORLIGREEN;

  DRAWTEXT(ISLASTBAR,100,'清仓'),COLORYELLOW;

  DRAWTEXT(ISLASTBAR,10,'吸筹'),COLORGREEN;

  MV3:=EMA(V,3);

  MA3:=EMA(C,3);

  MV3角度:=ATAN((MV3/REF(MV3,1)-1)*100)*180/3.1416;

  MA3角度:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;

  MV5:=EMA(V,5);

  MA5:=EMA(C,5);

  MV5角度:=ATAN((MV5/REF(MV5,1)-1)*100)*180/3.1416;

  MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

  MV10:=EMA(V,10);

  MA10:=EMA(C,10);

  MV10角度:=ATAN((MV10/REF(MV10,1)-1)*100)*180/3.1416;

  MA10角度:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

  强弱度:=(MV3角度+MA3角度+MV5角度+MA5角度+MV10角度+MA10角度)/6,COLORFFFFFF;

  十九强:=IF(强弱度>=80,80,0),COLOR0000FF,LINETHICK2;

  脱离MA5:=(L/MA(C,5)-1)*100,COLORFF9988,POINTDOT,LINETHICK0;

  DRAWTEXT(十九强 AND 脱离MA5>=3.5,108,'←险'),COLORGREEN;

  日:=150;昨前:=3;

  高1:=REF(HHV(H,日),昨前);

  顶:REFDATE(高1,DATE),COLORBLACK;

  绝顶:=REFDATE(顶,DATE),NODRAW;

  跑:=绝顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW;

  STICKLINE(跑,120,100,1,0),COLOR777777;

  STICKLINE(跑,120,100,1,0),COLORAAAAAA;

  STICKLINE(跑,120,100,1,0),COLORCCCCCC;

  STICKLINE(跑,120,100,0.1,0),COLORFFFFFF;

  STICKLINE(跑,120,100,1,0),COLORFFFFFF;

  DRAWTEXT(跑,阻力*1.03,'←绝顶逃')COLORGREEN;

底部介入指标

  源码中还通过强弱角度以及风险分界线进行研究分析的,示例如图平安银行的走势,从低点8.74元到9.80元上涨拉升,对应的底部介入指标中,强弱分界线是50,风险顶是100,买卖点是31.58,阻力在27.29,希望投资者及时把握介入的机会。

  【回踩关键位】

  N:=10;

  AN:MA(C,N);

  AN12:MA(AN,12);

  A1:=L

  A2:=C>AN;

  A3:=C/REF(C,1)

  A4:=CROSS(C,AN) AND V/REF(MA(V,5),1)>1.016;

  XG:=A1 AND A2 AND A3 AND A4;

  STICKLINE(AN>=AN12 AND XG,H,L,2,0),COLORLIRED;

  STICKLINE(AN

  {DRAWICON(XG,H,13);}

  DRAWTEXT(XG,L,'回踩关键位'),COLORYELLOW;

回踩关键位

  股价在上涨下跌的过程中,出现关键点位的回踩,具体的实战案例如图平安银行的走势,回踩的关键点位可以进行买卖交易。

  以上就是本文讲解的关于股市中底部介入指标以及回踩关键位指标的源码公式详解,如果您还想要了解更加专业的技术指标公式,请关注股票技术指标公式进行研究分析。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top